We go through some of the most impressive examples of the latest in display technology.
The Essential 4K Experiences
We sit down with Blizzard to talk about the Alliance, Horde, and Island Expeditions
World of Warcraft: Battle for Azeroth Interview
Retribution, the new PvE co-op mission now live in Overwatch finally delivers on the promise of fun story-based content.
Overwatch Retribution Delivers Fun PvE Story Content
Where we talk about lessons learned, the early experiments, and the evolution of PvE Overwatch.
Talking Overwatch Retribution with Game Director Jeff Kaplan
Brand new Alienware 17R2 blue screen every time a game using the GTX...
Millak
1 posts
Hey, I have had my alienware 17R2 laptop for 3 days now and for the first 2 days everything ran fine, however i did not have a driver for the GTX 970M card, so I installed Nvidia GeForce Experience and all the 300mb of drivers etc, and all of a sudden every time i try to load a game(CS:GO, CSS, Crysis 2) the screan goes into full screan mode as it normally does but then after the launch box disappears(steam games) it fails to launch, with crisis 2 i also get the message: "unsupported video card detected...". If i disable the GTX970 and run off the Intel 4600 then all the games run and everything works fine, it is just very low fps in game and i want the proper gaming card to run.

I have already done a clean reinstall of all Nvidia drivers and the same issue occurs

System Specs:

4th Generation Intel(R) Core(TM) i7-4720HQ Processor (Quad core, 8 threads, 6M Cache, up to 3.50 GHz);
16GB Dual Channel DDR3L 1600MHz (8GBx2);
128GB M.2 SSD + 1TB 5400RPM SATA 6Gb⁄s;
Windows(R) 8.1 (64Bit) English;
GeForce(R) GTX 970M with 3GB GDDR5;

Any help would be excellent, thanks!
12:51am 15/10/15 Permalink
system
Internet
--
12:51am 15/10/15 Permalink
Viper119
Other International
2803 posts
Sounds like a strange one. Have you checked the Alienware, Nvidia and Geforce support/forums? Probably a better chance of finding a solution there.

Is it auto detecting the driver to download/install through experience? Perhaps try downloading a specific driver from the Nvidia site instead.

There is a bunch of talk on the interwebs about stability and FPS issues with the 970 cards, I noted it when researching trying to get DA:I to run properly. Apparently it's a bit of a work in progress issue and Nvidia are supposed to be resolving it with future driver updates.
01:19am 15/10/15 Permalink
Spook
Brisbane, Queensland
39807 posts
have you uninstalled all nvidia stuff (experience/drivers) and reinstalled the drivers that came with laptop?

reimage/restore the laptop?
07:32am 15/10/15 Permalink
zaraq
Adelaide, South Australia
692 posts

Try here.http://en.community.dell.com/support-forums/

When you install you're drivers select custom install and deselect Ge force experience.

08:29am 15/10/15 Permalink
Millak
2 posts
I would have replied sooner, sorry, but my laptop froze every time I started it up, so I had to reinstall windows and all that jazz, i'll comment back on here if problms persist after I reinstall drivers(slow internet sorry guys may take a while)
thanks for the suggestions, i'll look into them all
01:00pm 15/10/15 Permalink
system
Internet
--
01:00pm 15/10/15 Permalink
AusGamers Forums
Show: per page
1
This thread is archived and cannot be replied to.