Our very first hands-on with Cyberpunk 2077 -- can this game truly live up to the hype? Read on for our full thoughts...
Cyberpunk 2077 Hands-On - A Life More Complicated
From mash-up to sampling to festival culture and dance music, Harmonix’s latest puts player choice and expression front-and-centre.
FUSER - Harmonix Sets its Sights on Festival Lights
The latest June 2020 quarterly update on Diablo IV is a treasure trove of new info, so let’s break it down.
Diablo 4 Update – Open World, Events, Legendary Gear, and More
As the latest LG OLED, the CX presents a high-end display that takes OLED technology forward in meaningful ways.
LG CX 65-inch 4K OLED - A Stunning Next-Gen Ready Display
TV WIFI Networking help?
Mephz
Brisbane, Queensland
1462 posts
Hey Guys, Trying to Get Sony Bravia TV working across my network.

The TV is DLNA certified.
TV is Sony Bravia KDL-60R550a (or something to that effect)

The problem is as follows:
The TV can access the internet via router WiFi.
The Router can see the TV attached (with no device name, it just has --), the TV does have a device name set. [The PS3 also displays as -- however I have no issues streaming to that so I dont think that's the issue)
The MAC address for the TV is correct.

The i.p the TV is displaying is correct (192.168.0.8).
Both my PC's can ping the TV and receive a response. (so the TV is definitely on the network)

The TV does not show up on either PC under Windows Vista (64) nor Windows 7 (64) under network [this I think is the issue?]

I was wondering if maybe this is a workgroup issue? There is no way to change that on the TV (then again nor the PS3 and it works fine).
I cannot see the TV under printers and devices, nor under advanced streaming settings.

Running out of ideas and done a lot of googling.
I've tried TVersity - It can see the PS3 but again, not the TV.

Would like to use my TV to stream directly but I'm stuck as anything now.

Any ideas?
06:46pm 22/09/13 Permalink
system
Internet
--
06:46pm 22/09/13 Permalink
Mephz
Brisbane, Queensland
1463 posts
I've tried a full shutdown and power-down of all devices simultaneously.
(PC's Off, Router Off, TV Off)
And then powering all back on. Didn't help much as I thought but you never know :)

TV still visible as an attached device on the router but not visible through either version of Windows.
Frustrating.

The TV is definitely capable of being streamed to via Windows 7 as well as I did find guides however I had already done all the steps. Could never find any mention of the TV not actually being 'visible' as a device on the network however.
06:54pm 22/09/13 Permalink
trillion
Brisbane, Queensland
3285 posts
i have a Bravia KDL-32EX720 and a KDL-47W800A in the theatre room and DLNA only works on the 32incher because of firmware between the two is different.

the 800A is a Sony OEM build of Android, and it's awesome, but it doesn't have the DLNA service and i suspect it's because of the (lack of) the licensing arrangement's with the Android mainline codebase.
06:59pm 22/09/13 Permalink
Mephz
Brisbane, Queensland
1464 posts
So it's possible its just never going to work and its not a network setup error?

the TV has no more options for me to explore to change so thought maybe a windows/router thing.
07:04pm 22/09/13 Permalink
shad
Brisbane, Queensland
4040 posts
My Sony doesn't appear in windows. I never thought it was an issue because the TV itself connects to the dlna server to pull the movies.

HX750 here.

last edited by shad at 19:10:23 22/Sep/13
07:09pm 22/09/13 Permalink
shad
Brisbane, Queensland
4041 posts
As it turns out I lied. I can see the Media Device. Are you trying to push video to it?
07:11pm 22/09/13 Permalink
Mephz
Brisbane, Queensland
1465 posts
I can't push videos to it as its not detected. Under streaming with windows its not a listed device and as such WMP has no play to option. TVersity doesn't see the TV and the TV doesn't see WMP or Tversity. My PS3 can see TVersity, WMP and PSMS as servers and pull media from them. TV doesn't see anything. Is there a way to work out what workgroup or whatever the TV is on?

For example. Under streaming permissions in windows my PS3 is displayed as.an unknown device not.under 'local.network' but under 'other networks' but it.still streams. Unfortunately TV doesn't show up regardless. TV is definitely.connected thougj. Frustrating problem :/
07:19pm 22/09/13 Permalink
crazymorton
Brisbane, Queensland
4490 posts
Tried turning off fire walls, anti virus software?

On PC and router, and allow the TV through your router.
08:33pm 22/09/13 Permalink
Mephz
Brisbane, Queensland
1466 posts
No firewalls or antivirus. Permissions from router should allow through automatically I would think. Never had.yonder anything special for ps3 or other devices on the network?
08:47pm 22/09/13 Permalink
Whoop
Brisbane, Queensland
22186 posts
my samsung tv works ok over the network, it's installed under devices and printers (windows 7), try looking in there and see if it has an exclamation point next to it.

I browse for media on the tv itself, I don't push to it from the computer mostly. Does that work for you? Though I can push to it from my phone (both samsung devices) but windows won't always see the TV, seems to be hit and miss. TV is always able to see the NAS though.

In windows there's an option to either let selected devices connect only, or to let all devices connect. Check to see if that's set properly
08:54pm 22/09/13 Permalink
Mephz
Brisbane, Queensland
1467 posts
TV doesn't see computers or vice versa. Pretty sure I have the devices set to allow all devices connect for streaming media. TV doesn't show up in network list. Doesn't appear under.devices and printers either.
09:42pm 22/09/13 Permalink
Whoop
Brisbane, Queensland
22187 posts
can you try ethernet? does your router have some kind of wifi block thing where it stops wifi clients from accessing the local network (usually for people who run after market firmware but newer routers have it as "guest mode")
10:53pm 22/09/13 Permalink
trillion
Brisbane, Queensland
3286 posts
can you confirm that it's a model of the Sony panel's that run's a build of Android?

if not and it's the proprietary firmware that Sony bake into their mid tier series, you'll probably need something like Openmediavault or a Linux instance somewhere on your network running DLNA as a daemon in the protocol stack servicing the media on your storage.
11:41pm 22/09/13 Permalink
Mephz
Brisbane, Queensland
1468 posts
trillion: I'm not sure how I would do that?

Whoop: The TV seems to show up just like the PS3 does (device name as -- on the attached list).
It's a netgear router (DGN2200)?
No guest mode or anything that I know of. I never had to do anything fancy for the PS3 to work.
TV can definitely access internet.

[edit] Definitely not a guest network, checked and they are all disabled. TV is definitely on the proper broadcasted network.

The TV has three modes of connecting to a network WPS (push button), WPS and WPA2-PSK.
I can find the WPS section of my router however it only has the PIN for the router itself. The TV when you select that mode says enter the PIN to the router which there is no option to do.

I've tried setting the MAC address of the TV basically to a full access allow-all and has made no difference :/
06:10am 23/09/13 Permalink
Mephz
Brisbane, Queensland
1469 posts
Definitely supports DLNA/LAN. I just cannot see the TV on my network.
I've also tried switching to just WPA mode on the router and 54Mbps incase that had anything to do with it. But to no success.
Double checked all security settings on windows etc. No problem. PC 1 and PC 2 communicate fine and can see the stream servers and access files/folders.
Just the TV does not show up on the network at all to either PC (Vista 64bit, Win 7 64 bit) nor able to see the stream servers.

I'm set to workgroups as 'WORKGROUP', can't find any information that Sony TV defaults a workgroup to anything etc. or if it's even necessary.

This is the Specs Manual of the TV from Sony:
http://www.docs.sony.com/release/specs/KDL60R520A_mkjavascript:void(0);sp.pdf
06:56am 23/09/13 Permalink
Spook
Brisbane, Queensland
36543 posts
so you have media in your dnla library? and the tv cant see that?

you shouldnt be pushing anything to the tv, the tv should be playing the media natively.

my samsung works like this, i add all my medias on the pc to my media library, my samsung tv sees network and connects, and then when i search media or surf to my videos on tv, all media in media list is there and plays (i just use wmp to build the library on pc)

would be extremely suprised if this isnt the case with your tv, its how every other smart tv ive seen works.
07:50am 23/09/13 Permalink
Mephz
Brisbane, Queensland
1470 posts
Well I can't push to the TV or play natively as nothing is detected.
the TV doesn't see the Windows Media Player server, Nor TVersity, Nor PlayStation Media Server (just had all running at once to see if it would see anything).

WMP V12 --> Stream --> Turn on Media Streaming --> all networks. I don't actually see the TV in this list, but allowed all anyway

Allow Remote Control of Player also selected.

WMP server appears under Networks.
TV still doesn't actually even appear on the network on either Vista 64 or Windows 7 PC's. Can be pinged from both though.

I have added Videos to the media library (as far as I'm aware) --> Under Videos on the left in WMP library I have all my videos.
08:13am 23/09/13 Permalink
Mephz
Brisbane, Queensland
1471 posts
Tried again to double check the media player library :(

Still nothing :/

No options under network either (just set up network / change TV name).
Gah
08:21am 23/09/13 Permalink
trillion
Brisbane, Queensland
3287 posts
if you need a callout for your clusterf***, SuperGeek have a small fleet of geek's somewhere nearby, probably ;P
09:21am 23/09/13 Permalink
ph33x
Thailand
85 posts
I've skipped a bit of the body of this thread:

Have you tried plugging the computer directly into the TV? Some routers do weird things across their ports, splitting subnets and separate VLANs etc. Direct connection to eliminate.
10:46am 23/09/13 Permalink
Spook
Brisbane, Queensland
36546 posts
so theres definately media in the library? ie you can search for stuff in wmp?

on my tv i can also connect to my pc directly and access media that way, can do?
11:45am 23/09/13 Permalink
Mephz
Brisbane, Queensland
1472 posts
Spook no I can't access pc at all. Definitely media in library can see it from other PC. TV doesn't show on network as a device to.the PCs (but then boe does the ps3 and it.can see PSMS)
12:19pm 23/09/13 Permalink
Whoop
Brisbane, Queensland
22188 posts
Checked for firmware? I had to manually update mine using USB because the online check didn't detect the new firmware.
12:25pm 23/09/13 Permalink
Mephz
Brisbane, Queensland
1473 posts
[edit] - Nope, PS3 can pull from WMP / TVersity.

TV just straight up not detected on the network and does not see the media servers.
On the second PC when setting up media share through WMP with a different version when setting the permissions the first PC is visible, 'unknown device' (which is the PS3) is visible etc. [PS3 then able to access WMP library from either PC's media server)
But no TV direct access.

I'm at a loss I don't know what else to try to make the thing visible on the network.
Short of carrying the thing closer to the PC and doing a direct connection and testing that way which given its 35kg and an awkward size I'm not going to do.
12:36pm 23/09/13 Permalink
Mephz
Brisbane, Queensland
1474 posts
[edit] Old post made irrelevant with some further testing, not sure how to just delete the post.
01:12pm 23/09/13 Permalink
Malthius
Brisbane, Queensland
919 posts
As a long shot, try PS3MediaServer ( http://www.ps3mediaserver.org/ ) - it is a DLNA media server (like TVersity), but since it is an open source project it has a lot more logging options. By default you can check the 'traces' tab to see everything that is going on, so if the TV is being detected then rejected for some reason it might be apparent there.

if that doesn't help, the PS3MediaServer forums might be able to help - there will be a lot more people there with exactly your model of TV than here.
01:58pm 23/09/13 Permalink
Mephz
Brisbane, Queensland
1475 posts
Cheers. I've tried PSMS as I use that for streaming to PS3 and TV didn't pick it up :(
I will try seeing if its picking anything up and rejecting it tomorrow but I am skeptical that it would be. It just doesn't appear to be communicating at all, just routing through for.the internet. The TVs diagnostic does say LAN ok. INTERNET ok.

04:21pm 23/09/13 Permalink
Whoop
Brisbane, Queensland
22189 posts
I just noticed on my TV's properties in windows, it has a UPnP tab. Do you have UPnP turned on in your router settings?

Did you check online (using your PC) for a firmware update yet? Mine had one but when you check online using the TV it would say it's up to date, yet there was an update available online for that model but I had to get it using my PC and put the firmware on a USB stick and plug that into the TV.

I can't help you about the showing up as an unnamed device on your router because I use dnsmasq and give all my devices names in the router anyway so even if the device itself doesn't tell the router hey I'm named blah, the router will name it anyway. Makes it way easier to access stuff without having to remember what has which IP.

If you've tried everything and the thing is definitely DLNA certified I would be calling up Sony with my angry voice and demanding either a replacement or a refund since it's clearly faulty.
05:07pm 23/09/13 Permalink
Mephz
Brisbane, Queensland
1477 posts
Thanks whoop I will check the uPnP thing in the morning. I would say a preliminary yes as the PS3 utilises UPnP I believe.
I will check if I can find a firmware update. Via internet in its own menus its already done an update and reckons its up to date. Will manually check on PC when I can.
As for the properties thing well I can't even detect the tv through windows in any shape or.form.
I'm sure it has to be some.networking issue I doubt its the TV. But for the life of Mr I have no idea.
07:35pm 23/09/13 Permalink
Tiny
Brisbane, Queensland
3397 posts
Hey Mehpz, i had one of these routers and had non stop issues with it. Setting up a VOIP modem through the router was a nightmare of port settings I had to check, even then it did weird s*** all the time i could never fully explain or make sense of.

I would lean towards all the suggestions in the thread, at least isolate your router as the issue by testing it via ethernet or even another router if you can get your hands on that. If you find it works with another router you can go from there...
08:15pm 23/09/13 Permalink
Mephz
Brisbane, Queensland
1478 posts
Thanks tiny you've given me an idea to try. I will try to allocate the TV a static i.p. and do a blanket port forward to my main pc. I wonder if that would make a difference. It almost seems like the TV is on a subnet of its own as its clearly accessing internet but not.discoverable on the network :/
11:16pm 23/09/13 Permalink
Whoop
Brisbane, Queensland
22192 posts
I will check if I can find a firmware update. Via internet in its own menus its already done an update and reckons its up to date. Will manually check on PC when I can.
As for the properties thing well I can't even detect the tv through windows in any shape or.form.
Yeah mine said it was up to date using the menu in the TV but on the PC there was a firmware update available.

I didn't mean you should check the properties as you already said it's not there. I just meant that I found it there which gave me the idea to tell you to check upnp. I should probably have just left that part out for clarity.

Can you access the networking part of your TV and check the subnet? I mean if your router is giving out IP's and subnets it should be giving them all compatible ones though so I doubt it would be that.

And just to rub dirt into your wounds, I've actually turned media streaming off completely in WMP under windows 7 (I never use it) and the option to play to my TV still shows up :p I think the media streaming thing must only apply if you're browsing FROM the TV. The TV should present itself over the network as a media display device.

Also in devices and printers right click on the name of your computer and go to "device installation settings" and make sure automatically download info from the internet is enabled. I remember once I accidentally clicked no when it first asked me and then it never asked me again and that was disabled. It made installing things rather difficult because it would never check windows update for drivers, I had to give it everything. So if you don't have a driver disc for the TV, it won't know what to do with it (if that setting is off).

edit: Oh and, go get yourself 100m of cat 5 cable and some 8pin rj45 connectors and make your own cable if you have to but do whatever it takes to try it with ethernet. It might mean carrying the PC over to the TV along with a switch but if you find that the issue goes away you'll have saved yourself all the hours of messing about trying different settings, not knowing whether or not the issue lies in the TV, the computer, the router or simply the fact that it's WiFi'd
01:05am 24/09/13 Permalink
Mephz
Brisbane, Queensland
1479 posts
I have a feeling that this TV actually just does not do direct streaming.
This somewhat pisses me off because numerous places that sell the TV list it as WiFi with DLNA.
Sony themselves list the TV as DLNA.

From sony themselves @ http://store.sony.com/p/60-inch-HDTV,-R-Series,-R520,-genie-whole-home-DVR,-smart-TV,-Full-HD/en/p/KDL60R520A

"Goodbye wires, hello Wi-Fi®.

Maximize your entertainment while reducing cable clutter. Wirelessly stream beautiful, HD entertainment straight from the internet or your home network using built-in Wi-Fi® connectivity.1"

From their support/downloads (manuals and firmware) , Marketing Specs:

Network Features
BIVL (System):
Yes

DLNA Content:
JPG/ MP3/ WMA/
MPEG1/ MPEG2PS/
MPEG2TS/ AVCHD/
MP4/ WMV

Internet_Browser:
Yes (Opera)
Opera Apps (System):
Yes
Screen mirroring:
Yes
Sony Entertainment Network:
Yes
TV Tweet:
Yes (Opera)
Wi-Fi Certified:
Yes
Wi-Fi Direct:
Yes
Wireless LAN:
Integrated


There is nowhere in the TV menu's to actually search for a DLNA server to browse media.
The manual only suggests the "media" menu is for USB only.
What a crock suggesting it's DLNA is then.

Furthermore.
PS3Media Server doesn't pick up the TV as a renderer/media device
Mezzmo Doesn't pick up the TV as a media device.
TVersity Doesn't pick up the TV as a media device.
WMP I cannot right click 'play-to' ...
02:10am 24/09/13 Permalink
Mephz
Brisbane, Queensland
1480 posts
Whoop: As for the TV presenting itself, the PS3 doesn't present itself either on the network (but it picks up the media servers).
What is interesting is that I could swear the PS3 used to present itself on my old router.

My two PCs are Cat5 connected to the router, but PS3 and TV using WiFi.
Do I somehow need to force them to be on the same network to be able to communicate properly? This doesn't make sense to me but just checking...
02:42am 24/09/13 Permalink
Spook
Brisbane, Queensland
36550 posts
if your tv wont play medias off the network, throw that s*** on the ground.

have we tried hardwired? my tv was slightly flakey on wireless, works a treat wired or eop
07:10am 24/09/13 Permalink
Mephz
Brisbane, Queensland
1481 posts
Im going to try wired via my Laptop. It's unfortunately adding another variable (the laptop setup) but at least I can rule that out.
Interestingly I tried WiFi Direct screen mirroring with my wifes mobile phone which supports it.
the TV acknowledges the phone and starts to connect with it then just says registering failed.

Don't have a tablet etc. to try.
I tried last night the laptop over wireless to see if it would see/connect to TV, no deal.
I've got the TV on a static/preferred I.P.
I'm not really sure how to port forward a LAN i.p port to LAN i.p port, as all port forwarding is WAN to LAN.
I'm assuming port forwarding within a LAN isn't really possible in the context I'd be trying as all internal LAN should automatically be port forwarded no?

Anyway, I'll give laptop a crack now. I was up til 3am after work but forgot to give that a try.

But even still I just don't have any options in the TV anywhere to search for DLNA/media servers. The only place I have such options, the manual seems to suggest that's for USB only (despite specs etc. everywhere as I posted suggesting this TV can stream over network).
07:22am 24/09/13 Permalink
Mephz
Brisbane, Queensland
1482 posts
No luck with wired via Laptop.
Again there is just no way of even searching for media servers. The only closest option still just says no devices found.
I am thinking this TV just won't do it.
Which is stupid given earlier models can do it.
Even more stupid that if I put things onto a USB and plug it in, it can do it. And it has the WiFi capability yet I can't stream over the WiFi, despite all specs suggesting it can.
False advertising/listing imo.
07:48am 24/09/13 Permalink
crazymorton
Brisbane, Queensland
4492 posts
Tried an ip release or router reset?

Also does your router do "Wireless connectivity requires 802.11 home network (802.11n recommended)." From their web site.

Can you see the TV in you routers list of devices using wifi?

If you can access the internet from the TV apps then your wifi is working so it must be a router or windows end problem?
08:24am 24/09/13 Permalink
Whoop
Brisbane, Queensland
22193 posts
You don't search for severs on mine either, it just detects them and when you press the source button you can pick either HDMI, RCA, TV tuner etc, and any dlna servers will show up in that list.
12:34pm 24/09/13 Permalink
Mephz
Brisbane, Queensland
1484 posts
yeah never got it to show up in source input either whoop :/
And the TV was never identified by any of the media Servers.
e.g. TVersity and PS3MediaServer identify PS3 (heck they even see WMP attached/accessing the media server) but no TV :/

In the end I can still stream via my PS3 as a media box/extender.
But it's more about
a) using the features the TV is supposed to have
b) sony cinevia s*** for some certain streams :P (god forbid it may be built into the TV itself anyway)
07:33pm 24/09/13 Permalink
Mephz
Brisbane, Queensland
1485 posts
Aaand I just realised the other reason I didn't want the PS3 as an extender. It's WiFi streaming that loves to throw random network errors all the time and require quickly stopping and starting the video/stream again. Zzzz
07:51pm 24/09/13 Permalink
Whoop
Brisbane, Queensland
22198 posts
If it were me I would call tech support (be it Sony or the store you got it from) and get them to run through all the possible ways to get it going. Then if it still doesn't work I'd go back to the store if it's within warranty period and go look a*******, you sold me this s*** claiming it has DLNA in it when clearly it doesn't, here's the transcript of my tech support call now give me a TV with DLNA in it and you f*****g better not charge me extra or give me a refund.

Might want to try politeness at first, leave the swearing until later when they inevitably refuse. Then start being firm with them and don't ask to speak to the store manager, demand to speak to the head office right.goddam.now.
09:14pm 24/09/13 Permalink
system
Internet
--
09:14pm 24/09/13 Permalink
AusGamers Forums
Show: per page
1
This thread is archived and cannot be replied to.